Full services have been restored by EE UK after an MSC resource, MSGS Pro, was identified as a potential bottleneck. A configuration update was applied. Follow‑up checks confirmed available capacity and utilisation were within expected ranges. After a period of monitoring, services have returned to business as usual with no further 2G SGS issues observed.
Posted Jun 30, 2026 - 08:25 CEST
Identified
We received an update from our roaming partner EE UK regarding the ongoing service disruption. The issue is affecting inbound voice and SMS services due to a problem within their network infrastructure. Their technical teams are actively working to restore normal service, and we will share further updates as soon as they become available.
Posted Jun 29, 2026 - 20:58 CEST
Update
Our technical engineers have initiated an investigation with our key roaming partner, EE UK. We have also contacted to emphasize the priority of this incident. EE has informed us that there is an ongoing issue in their network; they are aware of it and are actively working to resolve it.
Posted Jun 29, 2026 - 20:05 CEST
Investigating
Investigation is ongoing, with Mobile Core and Roaming teams actively analyzing the issue. Initial checks show no indication of a Core-related cause, and further analysis is focused on the SMS delivery path towards EE UK.