This incident has been resolved. We are still awaiting more insight from iBasis into the cause of the issue. A root cause analysis will be shared with all customers who have registered an incident ticket.
Posted Jul 25, 2025 - 16:13 CEST
Update
The issue appears to be resolved, and ongoing business checks continue to show positive results. We continuing to monitor the issue. Below is a list of monitoring alarms, including the timestamps for when each alarm was triggered and cleared.
Multiple customers have confirmed that service has been restored. We are currently conducting business checks with all affected customers and awaiting confirmation of the fix from our partner, iBasis. Next business call is at 15:00 CET and an update will follow shortly after.
Posted Jul 25, 2025 - 14:32 CEST
Update
The incident began around 12:30 CET, when our monitoring systems alerted the roaming team. Since then, we have been actively troubleshooting the issue in collaboration with our partner, iBasis. We are currently awaiting their update.
Just now, our monitoring indicates that services may have been restored, but we are awaiting confirmation.
Posted Jul 25, 2025 - 14:23 CEST
Investigating
We are currently investigating this issue. We see a degradation in our monitoring and multiple customers have reported problems.