Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 24, 2025 - 00:01 CEST
Scheduled
On Thursday 24 July between 00:01 and 02:00 (CEST), there may be a short interruption in active sessions. The interruption lasts less than 1 minute. After the interruption, the session is automatically restored.
Posted Jul 10, 2025 - 21:47 CEST
This scheduled maintenance affected: M2M Connectivity.